Thursday, March 27, 2014

[ISSUE] Problem upgrading to Centos 6.5 – perl-CGI dependancy

downloadCentOS 6.5 has just been released but it seems that cPanel gets unhappy about a perl-CGI dependancy for one of the redhat packages. Specifically it gives this error:

root@bandit [~]# yum update
...
---> Package redhat-lsb-core.x86_64 0:4.0-7.el6.centos will be installed
--> Processing Dependency: perl-CGI for package: redhat-lsb-core-4.0-7.el6.centos.x86_64
---> Package xz.x86_64 0:4.999.9-0.3.beta.20091007git.el6 will be installed
--> Finished Dependency Resolution
Error: Package: redhat-lsb-core-4.0-7.el6.centos.x86_64 (base)
Requires: perl-CGI
You could try using --skip-broken to work around the problem
** Found 1 pre-existing rpmdb problem(s), 'yum check' output follows:
frontpage-2002-SR1.2.i386 has missing requires of libexpat.so.0

Not ideal.

This will also break if you’re using the /usr/local/cpanel/scripts/upcp or the update option via the WHM web interface.

To fix the issue we need to remove the perl* exclusion from yum.conf which cpanel sets:
cp /etc/yum.conf /etc/yum.conf.backupsed -i 's/ perl\*//' /etc/yum.confThis should have just removed the perl* from the exclusion line in the yum.conf. If you want to make sure you can compare the before and after using:diff /etc/yum.conf /etc/yum.conf.backupNow you should be able to run ‘yum update’ or ‘/usr/local/cpanel/scripts/upcp’ and all should be well.

Author:

0 komentar: